Joomla! Tutorials: Using jUpgrade to Migrate from 1.5 to 1.6

SUBSCRIBE FOR MORE! Joomla 1.5 to 1.6 is not an upgrade – it is a migration. This tutorial shows you how to use jUpgrade to complete the process. Please remember, many 3rd-party extensions are not currently available for 1.6, so check which ones you use before attempting the migration. For more information, see: docs.joomla.org Visit www.joomla.org to download Joomla! Today and start building websites and applications! Join the community community.joomla.org Meet other Joomla! People people.joomla.org Find a local group community.joomla.org Get help in the forums: forum.joomla.org Learn the Documentation docs.joomla.org Extend Joomla extensions.joomla.org Find professional services resources.joomla.org Explore the magazine magazine.joomla.org Develop with Joomla developer.joomla.org Special thanks to Jon Neubauer for producing this tutorial jonneubauer.com

25 Comments

  • i just did this and the site at /jupgrade doesn’t look or work right at all. The template is gone. Nothing works but the login. Will the site work again after moving everything out of /jupgrade? HELP!!!

  • It’s worse than i thought. i logged in as admin and all the components and modules i installed are gone. It’s like a clean install.

  • The upgrade seemed to go well & I have everything perfect on the back end, but when I go to view site I get a 404 not found error. Not sure what happened

  • It is unbelievable disasterous component. Be careful and just try and fail how it doesn’t work.. you should try it on a dummy installation rather than a live site.. It would be a huge mistake..

  • Good video, but the problem is most of joomla1.5 templates are not competitable with 1.6 platform and this will create errors after mgration. So make sure that your template is 1.6 friendly and all your modules and plugins are 1.6 competitable before you do this…

  • I’m having the same thing happen. Says it is preparing for check, but stays there for hours. Tried a couple of different browsers. Status bar says there is an error on the page.

  • ok – found a solution on the forum.

    Needed to enable the plugin – System – Mootools upgrade in the plugin manager.

    So far so good at least it has moved on from checking

  • okay so I updated from 1.5.15 to 1.5.22 but when I try to run jupgrade I get this “Mootools 1.2 not loaded. Please enable “System – Mootools Upgrade” plugin. ” and when I click on it to go to my plug ins page. I dont have this plug in listed anywhere so where and how do I install this plug in so I can then us jupgrade? thanks

  • @FlipThatPC okay figured it out, its not Chrome friendly, launched it under FireFox and I was able to start the process but new problem, how long does it generally take to get through the download phase? I have been sitting here for like 20+ minutes and I see the lines moving across the screen but it doesnt fill up in red like shown in this video.

  • @FlipThatPC alright bypassed the download and got it to complete but sadly looks like Im going to have to wait until your 3rd party component part is implemented as the site just errors and Im sure this is part of the reason.

  • It is nice,but can anyone tell me,if i use Jupgrade,will my modules get upgraded ? My pivture viewer ant other components are compatible just with joomla 1.5,so will everything be lost,if i upgrade to 1.6 ??? Thanks for response.

  • @whufee So,i have template 1.5,and ALL modules (i have too much of them on my site) are for joomla 1.5.So if i migrate on joomla 1.6 i will just lose EVERYTHING ? :((

  • @Magareyt yes, im 99% sure you will have errors/ crush on your website after the migration. because 1.5’s extensions may not working under the new structure (1.6). The best solution for you is, install 1.6 on your local machine and test if they are working. I did this before i tend to upgrade, lots of errors and some of the key components are not even show under joomla1.6, so i decided to wait for another few months until my current extensions and components are 1.6 native.

  • @whufee Thank you very much for answer.I have one more question,is there any component that helps me to upgrade my modules and components automaticaly,so i do not have to download one by one component for Joomla 1.6 ? It will take so much time 🙁 Sorry for my bad english by the way if i made mistakes.

  • You are welcome, i dont think there is one for doing that… (update components and modules). Because, you should treat 1.5 and 1.6 are ‘ 2 separate things’. The easiest way to upgrade your component and module is check if there are 1.6 version for your website. if they dont have it for 1.6 now, just wait :D.
    I dont think you need 1.6 for now, it is still not 100% stable and may need further test. On the other hand 1.5 does 99% of work of 1.6, so i personally dont recommand you upgrade now.

  • can i delete the “oldsite folder” after 1.6 is successfully installed??? as the backup file of my new joomla 1.6 site is now a massive 65 mb lol, because it contains the old site along with it. is it safe to delete the oldsite folder i placed the old 1.5 site in?

  • Downloaded, installed, when I navigate to the component it does nothing. It just shows the image to begin upgrade, but it is just that… an image. It isn’t a button. So the latest version of the component doesn’t seem to be working.

Leave a Reply

Your email address will not be published. Required fields are marked *